// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\sUsername\s'(?<username>[^']+)'.*\n.*\(/(?<ipaddress>[^\)]+)\).*Failed\sto\sverify\susername").unwrap();
let string = "[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!
[18:56:57] [User Authenticator #2/ERROR]: Username '***' tried to join with an invalid session
[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}