import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\sUsername\\s'(?<username>[^']+)'.*\\n.*\\(/(?<ipaddress>[^\\)]+)\\).*Failed\\sto\\sverify\\susername";
final String string = "[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!\n"
+ "[18:56:57] [User Authenticator #2/ERROR]: Username '***' tried to join with an invalid session\n"
+ "[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}