# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/.*\\/(?!.*\\/.+))/$1/gm;t' <<< "site.com/foo/remove-me/
site.com/user/account/info/settings
site.com/foo/bar/remove-me
site.com/foo/remove-me?param1=true¶m2=hello+world
"