import re
regex = re.compile(r"(\/.*\/(?!.*\/.+))", flags=re.MULTILINE)
test_str = ("site.com/foo/remove-me/\n"
"site.com/user/account/info/settings\n"
"site.com/foo/bar/remove-me\n"
"site.com/foo/remove-me?param1=true¶m2=hello+world\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)