#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/.*\/(?!.*\/.+))"
Local $sString = "site.com/foo/remove-me/" & @CRLF & _
"site.com/user/account/info/settings" & @CRLF & _
"site.com/foo/bar/remove-me" & @CRLF & _
"site.com/foo/remove-me?param1=true¶m2=hello+world" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)