re = /(\/.*\/(?!.*\/.+))/m
str = 'site.com/foo/remove-me/
site.com/user/account/info/settings
site.com/foo/bar/remove-me
site.com/foo/remove-me?param1=true¶m2=hello+world
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result