const regex = /(\/.*\/(?!.*\/.+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/.*\\\/(?!.*\\\/.+))', 'gm')
const str = `site.com/foo/remove-me/
site.com/user/account/info/settings
site.com/foo/bar/remove-me
site.com/foo/remove-me?param1=true¶m2=hello+world
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);