#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$"
Local $sString = "WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115" & @CRLF & _
"" & @CRLF & _
"WAYFAIR, LLC/CSN LLC " & @CRLF & _
"17725 HUNTINGTON AVE. " & @CRLF & _
"BOSTON MA 02115"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")