import Foundation
let pattern = #"[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115
WAYFAIR, LLC/CSN LLC
17725 HUNTINGTON AVE.
BOSTON MA 02115
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)