import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$";
final String string = "WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115\n\n"
+ "WAYFAIR, LLC/CSN LLC \n"
+ "17725 HUNTINGTON AVE. \n"
+ "BOSTON MA 02115";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}