package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$`)
var str = `WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115
WAYFAIR, LLC/CSN LLC
17725 HUNTINGTON AVE.
BOSTON MA 02115`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}