// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$").unwrap();
let string = "WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115
WAYFAIR, LLC/CSN LLC
17725 HUNTINGTON AVE.
BOSTON MA 02115";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}