$re = '/[0-9]{5}$|^[A-Z][0-9][A-Z] ?[0-9][A-Z][0-9]$/m';
$str = 'WAYFAIR, LLC/CSN LLC 17725 HUNTINGTON AVE. BOSTON MA 02115
WAYFAIR, LLC/CSN LLC
17725 HUNTINGTON AVE.
BOSTON MA 02115';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);