#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*(class)\s*test1(\s|(\s*:|:))"
Local $sString = "class test1" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1 " & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1:sdfsdf" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1 :sdfsdf" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test1 :sdfsdf{}" & @CRLF & _
"public class test1 :sdfsddf{}" & @CRLF & _
"public class test11 :sdfsdf{}" & @CRLF & _
"public class test11 :sdfsdf" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test11" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"public class test11 :sdfsdfsdf {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")