using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(class)\s*test1(\s|(\s*:|:))";
string input = @"class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1:sdfsdf
{
}
public class test1 :sdfsdf
{
}
public class test1 :sdfsdf{}
public class test1 :sdfsddf{}
public class test11 :sdfsdf{}
public class test11 :sdfsdf
{
}
public class test11
{
}
public class test11 :sdfsdfsdf {}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}