re = /.*(class)\s*test1(\s|(\s*:|:))/
str = 'class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1:sdfsdf
{
}
public class test1 :sdfsdf
{
}
public class test1 :sdfsdf{}
public class test1 :sdfsddf{}
public class test11 :sdfsdf{}
public class test11 :sdfsdf
{
}
public class test11
{
}
public class test11 :sdfsdfsdf {}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end