$re = '/.*(class)\s*test1(\s|(\s*:|:))/';
$str = 'class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1
{
}
public class test1:sdfsdf
{
}
public class test1 :sdfsdf
{
}
public class test1 :sdfsdf{}
public class test1 :sdfsddf{}
public class test11 :sdfsdf{}
public class test11 :sdfsdf
{
}
public class test11
{
}
public class test11 :sdfsdfsdf {}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);