import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(class)\\s*test1(\\s|(\\s*:|:))";
final String string = "class test1\n"
+ "{\n"
+ "}\n"
+ "public class test1\n"
+ "{\n"
+ "}\n"
+ "public class test1\n"
+ "{\n"
+ "}\n"
+ "public class test1 \n"
+ "{\n"
+ "}\n"
+ "public class test1:sdfsdf\n"
+ "{\n"
+ "}\n"
+ "public class test1 :sdfsdf\n"
+ "{\n"
+ "}\n"
+ "public class test1 :sdfsdf{}\n"
+ "public class test1 :sdfsddf{}\n"
+ "public class test11 :sdfsdf{}\n"
+ "public class test11 :sdfsdf\n"
+ "{\n"
+ "}\n"
+ "public class test11\n"
+ "{\n"
+ "}\n"
+ "public class test11 :sdfsdfsdf {}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}