#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Help\s*#\s*(\d{3,5})\b"
Local $sString = "Help # 7256 " & @CRLF & _
"Help # 83930 " & @CRLF & _
"ph # 7222" & @CRLF & _
"this is a test example" & @CRLF & _
"Help # 029299" & @CRLF & _
"New # 92929"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")