const regex = /^Help\s*#\s*(\d{3,5})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Help\\s*#\\s*(\\d{3,5})\\b', 'gm')
const str = `Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}