using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Help\s*#\s*(\d{3,5})\b";
string input = @"Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}