$re = '/^Help\s*#\s*(\d{3,5})\b/m';
$str = 'Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);