re = /^Help\s*#\s*(\d{3,5})\b/m
str = 'Help # 7256
Help # 83930
ph # 7222
this is a test example
Help # 029299
New # 92929'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end