package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(^[a-z]{1}\d{4}[a-z]{3}$|^\d{4}$)`)
var str = `1001
1106
x1001abc
1111
AAAA
a111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}