$re = '/(^[a-z]{1}\d{4}[a-z]{3}$|^\d{4}$)/mi';
$str = '1001
1106
x1001abc
1111
AAAA
a111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);