re = /(^[a-z]{1}\d{4}[a-z]{3}$|^\d{4}$)/mi
str = '1001
1106
x1001abc
1111
AAAA
a111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end