using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#]+)[ \t]+([\S]+[^\n]+)";
string input = @"# header with spaces👍
#noheader
#
# 🔥123
asdasdasd
# 🔥
# This is 🔥
#
# header
# dasdadsa
## dasd
### asdas
#### asdasd
# adsasd";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}