package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([#]+)[ \t]+([\S]+[^\n]+)`)
var str = `# header with spaces👍
#noheader
#
# 🔥123
asdasdasd
# 🔥
# This is 🔥
#
# header
# dasdadsa
## dasd
### asdas
#### asdasd
# adsasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}