import re
regex = re.compile(r"([#]+)[ \t]+([\S]+[^\n]+)", flags=re.MULTILINE | re.UNICODE)
test_str = ("# header with spaces👍\n"
"#noheader\n"
"# \n"
"# 🔥123\n\n"
"asdasdasd\n"
"# 🔥\n"
"# This is 🔥\n"
"#\n"
"# header\n"
"# dasdadsa\n"
"## dasd\n"
"### asdas\n"
"#### asdasd\n\n\n"
" # adsasd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")