re = /([#]+)[ \t]+([\S]+[^\n]+)/m
str = '# header with spaces👍
#noheader
#
# 🔥123
asdasdasd
# 🔥
# This is 🔥
#
# header
# dasdadsa
## dasd
### asdas
#### asdasd
# adsasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end