import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{4}\\b\\s*\\b[A-Z]{3,11}\\s*\\b(?!(INTE|MANU|PMNT|Payment)\\b)[A-Z]{3,10}\\s*";
final String string = "2423 rfder INTE\n"
+ "2423 rfder MANUS\n"
+ "2423 rfder PMNT\n"
+ "2423 rfder Payment\n"
+ "2423 rfder Payments\n"
+ "2423 rfder wefwsfg\n"
+ "2423 rfder afafafddd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}