re = /\b\d{4}\b\s*\b[A-Z]{3,11}\s*\b(?!(INTE|MANU|PMNT|Payment)\b)[A-Z]{3,10}\s*/im
str = '2423 rfder INTE
2423 rfder MANUS
2423 rfder PMNT
2423 rfder Payment
2423 rfder Payments
2423 rfder wefwsfg
2423 rfder afafafddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end