import re
regex = re.compile(r"\b\d{4}\b\s*\b[A-Z]{3,11}\s*\b(?!(INTE|MANU|PMNT|Payment)\b)[A-Z]{3,10}\s*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("2423 rfder INTE\n"
"2423 rfder MANUS\n"
"2423 rfder PMNT\n"
"2423 rfder Payment\n"
"2423 rfder Payments\n"
"2423 rfder wefwsfg\n"
"2423 rfder afafafddd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")