const regex = /\b\d{4}\b\s*\b[A-Z]{3,11}\s*\b(?!(INTE|MANU|PMNT|Payment)\b)[A-Z]{3,10}\s*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\b\\s*\\b[A-Z]{3,11}\\s*\\b(?!(INTE|MANU|PMNT|Payment)\\b)[A-Z]{3,10}\\s*', 'igm')
const str = `2423 rfder INTE
2423 rfder MANUS
2423 rfder PMNT
2423 rfder Payment
2423 rfder Payments
2423 rfder wefwsfg
2423 rfder afafafddd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}