# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+)( )([A-z\s0-9]+)/\1\3/gm;t' <<< "10 990 Points"