const regex = /([0-9]+)( )([A-z\s0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+)( )([A-z\\s0-9]+)', 'gm')
const str = `10 990 Points`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);