re = /([0-9]+)( )([A-z\s0-9]+)/m
str = '10 990 Points'
subst = '\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result