use strict;
my $str = 'write a function +n';
my $regex = qr/\b[a-z]{1,2}\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";