#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[\K([^ \]]+)(?=\])"
Local $sString = "[text* your-name]" & @CRLF & _
"[email* your-email]" & @CRLF & _
"[text your-subject]" & @CRLF & _
"[textarea your-message]" & @CRLF & _
"[submit "Verzenden"]" & @CRLF & _
"[your-subject]" & @CRLF & _
"[your-name]" & @CRLF & _
"[your-email]" & @CRLF & _
"[your-message]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")