using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[\K([^ \]]+)(?=\])";
string input = @"[text* your-name]
[email* your-email]
[text your-subject]
[textarea your-message]
[submit ""Verzenden""]
[your-subject]
[your-name]
[your-email]
[your-message]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}