import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[\\K([^ \\]]+)(?=\\])";
final String string = "[text* your-name]\n"
+ "[email* your-email]\n"
+ "[text your-subject]\n"
+ "[textarea your-message]\n"
+ "[submit \"Verzenden\"]\n"
+ "[your-subject]\n"
+ "[your-name]\n"
+ "[your-email]\n"
+ "[your-message]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}