$re = '/^\[\K([^ \]]+)(?=\])/m';
$str = '[text* your-name]
[email* your-email]
[text your-subject]
[textarea your-message]
[submit "Verzenden"]
[your-subject]
[your-name]
[your-email]
[your-message]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);