re = /^\[\K([^ \]]+)(?=\])/m
str = '[text* your-name]
[email* your-email]
[text your-subject]
[textarea your-message]
[submit "Verzenden"]
[your-subject]
[your-name]
[your-email]
[your-message]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end