import re
regex = re.compile(r"^\[\K([^ \]]+)(?=\])", flags=re.MULTILINE)
test_str = ("[text* your-name]\n"
"[email* your-email]\n"
"[text your-subject]\n"
"[textarea your-message]\n"
"[submit \"Verzenden\"]\n"
"[your-subject]\n"
"[your-name]\n"
"[your-email]\n"
"[your-message]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")