import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a-z]?[A-Z]+\\w*(?: [a-z]?[A-Z]+\\w*)+";
final String string = "Moby Dick or the White Whale by Herman Melville\n"
+ "Winne The Pooh by A. A. Milne\n"
+ "Kim by Rudyard Kipling\n"
+ "The United States of America\n"
+ "The United States Of America\n"
+ "WWF PandaLogo\n"
+ "US Navy\n"
+ "iPhone\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}