// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-z]?[A-Z]+\w*(?: [a-z]?[A-Z]+\w*)+").unwrap();
let string = "Moby Dick or the White Whale by Herman Melville
Winne The Pooh by A. A. Milne
Kim by Rudyard Kipling
The United States of America
The United States Of America
WWF PandaLogo
US Navy
iPhone
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}