import Foundation
let pattern = #"\b[a-z]?[A-Z]+\w*(?: [a-z]?[A-Z]+\w*)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Moby Dick or the White Whale by Herman Melville
Winne The Pooh by A. A. Milne
Kim by Rudyard Kipling
The United States of America
The United States Of America
WWF PandaLogo
US Navy
iPhone
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)