const regex = /\b[a-z]?[A-Z]+\w*(?: [a-z]?[A-Z]+\w*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z]?[A-Z]+\\w*(?: [a-z]?[A-Z]+\\w*)+', 'gm')
const str = `Moby Dick or the White Whale by Herman Melville
Winne The Pooh by A. A. Milne
Kim by Rudyard Kipling
The United States of America
The United States Of America
WWF PandaLogo
US Navy
iPhone
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}