re = /\b[a-z]?[A-Z]+\w*(?: [a-z]?[A-Z]+\w*)+/m
str = 'Moby Dick or the White Whale by Herman Melville
Winne The Pooh by A. A. Milne
Kim by Rudyard Kipling
The United States of America
The United States Of America
WWF PandaLogo
US Navy
iPhone
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end