import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\d\\._%+-]+@[\\w\\d.-]+\\.[\\w]{2,4}";
final String string = "zzzz@mygmail.com\n"
+ "coolio.jones@mygmail.com\n"
+ "myinvalid&crazy*email@ziggybot.co.uk\n"
+ "http://memberpress.com\n"
+ "Meet me @ 5:00 in the Lobby\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}